Telescopes and Mounts

  • Forum
    Topics
    Posts
    Last post
  • Active topics
    Replies
    Views
    Last post
  • Telescope Mount Payload Capacity
    by JayTee United States of America »
    18 Replies
    46089 Views
    Last post by SkyHiker United States of America
  • Achromat Vs Semi-APO Vs APO - What's The Difference?
    by JayTee United States of America »
    59 Replies
    80893 Views
    Last post by Bigzmey United States of America
  • a new kind of tripod.
    by messier 111 Canada »
    6 Replies
    129 Views
    Last post by StarHugger United States of America
  • Meade 102 ED triplet objective clean,
    by johnyjf Great Britain »
    18 Replies
    885 Views
    Last post by John Baars Netherlands
  • ZWO AM5N upgraded mount
    by Caddman United States of America »
    0 Replies
    32 Views
    Last post by Caddman United States of America
  • ZWO Seestar 50
    by Star Dad United States of America »
    18 Replies
    471 Views
    Last post by Gfamily Wales
  • My cats photo
    by Bigzmey United States of America »
    8 Replies
    5076 Views
    Last post by JayTee United States of America
  • Celestron NexStar GPS alignment issues
    by jruckgaber »
    25 Replies
    4481 Views
    Last post by JayTee United States of America
  • Meade LX90 Battery Pack Replacement - Lead Question
    by Donnabzy United States of America »
    5 Replies
    227 Views
    Last post by Bigzmey United States of America
  • ES OTA Not Suited to Install A Vixen-Synta Finder Foot
    by JayTee United States of America »
    9 Replies
    289 Views
    Last post by JayTee United States of America
  • Ioptron CEM Mounts, full 4D balance
    by AstroShed Great Britain »
    5 Replies
    337 Views
    Last post by JayTee United States of America
  • Askar (SharpStar) Vs ZWO - Request for opinions
    by chris_g United States of America »
    5 Replies
    1650 Views
    Last post by atl613 United States of America
  • Duel Rig Mounting plate CEM120EC2
    by starman Great Britain »
    10 Replies
    366 Views
    Last post by AstroBee United States of America
  • More Problems with the HEQ5 Pro
    by Chiefsmith Netherlands »
    7 Replies
    455 Views
    Last post by Graeme1858 Great Britain
  • Orion spaceprobe 130st to Celestron edge 8”?
    by Siggy6 United States of America »
    6 Replies
    416 Views
    Last post by Bigzmey United States of America
  • Old Celestron C8 on a clock drive mount
    by vk6kb Australia »
    2 Replies
    287 Views
    Last post by yobbo89 Australia
  • Do you re-grease your GEM goto mounts?
    by Bigzmey United States of America »
    5 Replies
    282 Views
    Last post by Graeme1858 Great Britain
  • Your refractor - let's see it
    by Nakedgun United States of America »
    196 Replies
    79343 Views
    Last post by Ylem United States of America
  • Model Number for this Scope?
    by Orion231 United States of America »
    8 Replies
    434 Views
    Last post by JayTee United States of America
  • Refractor comparison old vs new
    by Lady Fraktor Slovakia »
    15 Replies
    771 Views
    Last post by John Baars Netherlands
  • Svbony sv225
    by Ylem United States of America »
    11 Replies
    706 Views
    Last post by Bigzmey United States of America
  • CEM60- Not pointing to the chosen target
    by biswasg India »
    9 Replies
    450 Views
    Last post by biswasg India
  • AZ-EQ6 Fails to switch ON.
    by Twizzle Wales »
    10 Replies
    505 Views
    Last post by yobbo89 Australia
  • F30070 Telescope – a review
    by Barnacle »
    8 Replies
    20007 Views
    Last post by rob&ert United States of America
  • CEM 60- Home, Zero and Park positions
    by biswasg India »
    1 Replies
    272 Views
    Last post by KathyNS Canada

Return to Board Index