iOptron mounts

Discuss iOptron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • Serial connection with CEM120?
    by turboscrew »
    4 Replies
    93 Views
    Last post by turboscrew
  • CEM120 gear problems
    by turboscrew »
    14 Replies
    1540 Views
    Last post by turboscrew
  • OK, Now My New Mount Is Really Here!!!
    by JayTee »
    14 Replies
    286 Views
    Last post by turboscrew
  • iOptron Az Mount Pro
    by smp »
    18 Replies
    5573 Views
    Last post by messier 111
  • Brand New Owner of an iOptron CEM120 Mount.
    by turonrambar »
    4 Replies
    230 Views
    Last post by turboscrew
  • My New Mount Is Here, My New Mount Is Here, My New Mount Is Here,
    by JayTee »
    15 Replies
    612 Views
    Last post by KingNothing13
  • CEM40
    by 515bonner »
    6 Replies
    2323 Views
    Last post by 515bonner
  • Just Ordered My CEM 70 Mount –– Again!
    by JayTee »
    9 Replies
    339 Views
    Last post by notFritzArgelander
  • iOptron AZ Mount Pro First light
    by Bigzmey »
    8 Replies
    1035 Views
    Last post by delgado39
  • iOptron CEM26
    by pixelsaurus »
    1 Replies
    565 Views
    Last post by bobharmony
  • Ioptron GEM45
    by Ngc1514 »
    3 Replies
    600 Views
    Last post by dagadget
  • AZ Mount Pro Altitude Lock and Counterweight Shaft Lock
    by BaloSurf »
    1 Replies
    410 Views
    Last post by Lady Fraktor
  • iOptron CEM70G iGuider is not recognized by windows10
    by Agnes »
    1 Replies
    669 Views
    Last post by turboscrew
  • Tripod Rubber Boot
    by 515bonner »
    6 Replies
    1606 Views
    Last post by Richardl1743
  • Polare alignment of IEQ 30
    by dagadget »
    9 Replies
    2868 Views
    Last post by dagadget
  • CEM40EC oblong stars... :(
    by StarCruz53 »
    5 Replies
    1211 Views
    Last post by Graeme1858
  • ZWO Focuser and iOptron Mount
    by 515bonner »
    0 Replies
    431 Views
    Last post by 515bonner
  • GEM28ec, anybody using one yet?
    by 7awol »
    3 Replies
    646 Views
    Last post by dagadget
  • Hand Controller Mount
    by 515bonner »
    4 Replies
    1933 Views
    Last post by JayTee
  • CEM 70G Balance Issues
    by lostone »
    0 Replies
    491 Views
    Last post by lostone
  • CEM120
    by turboscrew »
    10 Replies
    2316 Views
    Last post by turboscrew
  • CEM40 EC Review Part 1
    by STEVE333 »
    10 Replies
    9421 Views
    Last post by Peter802
  • Lack of CEM40 posts??
    by rayincorrales »
    1 Replies
    1098 Views
    Last post by JayTee
  • I-Optron CEM 120 EC2
    by starman »
    5 Replies
    1876 Views
    Last post by starman
  • CEM-60 likes perfect balance!
    by KathyNS »
    10 Replies
    1979 Views
    Last post by KathyNS
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum