iOptron mounts

Discuss iOptron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • iOptron Az Mount Pro
    by smp »
    19 Replies
    6009 Views
    Last post by Starmanflorida
  • Hand Controller Mount
    by 515bonner »
    8 Replies
    2258 Views
    Last post by JayTee
  • Guiding with the CEM70EC
    by AstroBee »
    1 Replies
    118 Views
    Last post by JayTee
  • Serial connection with CEM120?
    by turboscrew »
    4 Replies
    396 Views
    Last post by turboscrew
  • CEM120 gear problems
    by turboscrew »
    14 Replies
    1870 Views
    Last post by turboscrew
  • OK, Now My New Mount Is Really Here!!!
    by JayTee »
    14 Replies
    536 Views
    Last post by turboscrew
  • Brand New Owner of an iOptron CEM120 Mount.
    by turonrambar »
    4 Replies
    450 Views
    Last post by turboscrew
  • My New Mount Is Here, My New Mount Is Here, My New Mount Is Here,
    by JayTee »
    15 Replies
    828 Views
    Last post by KingNothing13
  • CEM40
    by 515bonner »
    6 Replies
    2572 Views
    Last post by 515bonner
  • Just Ordered My CEM 70 Mount –– Again!
    by JayTee »
    9 Replies
    541 Views
    Last post by notFritzArgelander
  • iOptron AZ Mount Pro First light
    by Bigzmey »
    8 Replies
    1286 Views
    Last post by delgado39
  • iOptron CEM26
    by pixelsaurus »
    1 Replies
    729 Views
    Last post by bobharmony
  • Ioptron GEM45
    by Ngc1514 »
    3 Replies
    823 Views
    Last post by dagadget
  • AZ Mount Pro Altitude Lock and Counterweight Shaft Lock
    by BaloSurf »
    1 Replies
    567 Views
    Last post by Lady Fraktor
  • iOptron CEM70G iGuider is not recognized by windows10
    by Agnes »
    1 Replies
    860 Views
    Last post by turboscrew
  • Tripod Rubber Boot
    by 515bonner »
    6 Replies
    1811 Views
    Last post by Richardl1743
  • Polare alignment of IEQ 30
    by dagadget »
    9 Replies
    3121 Views
    Last post by dagadget
  • CEM40EC oblong stars... :(
    by StarCruz53 »
    5 Replies
    1399 Views
    Last post by Graeme1858
  • ZWO Focuser and iOptron Mount
    by 515bonner »
    0 Replies
    584 Views
    Last post by 515bonner
  • GEM28ec, anybody using one yet?
    by 7awol »
    3 Replies
    881 Views
    Last post by dagadget
  • CEM 70G Balance Issues
    by lostone »
    0 Replies
    631 Views
    Last post by lostone
  • CEM120
    by turboscrew »
    10 Replies
    2618 Views
    Last post by turboscrew
  • CEM40 EC Review Part 1
    by STEVE333 »
    10 Replies
    9883 Views
    Last post by Peter802
  • Lack of CEM40 posts??
    by rayincorrales »
    1 Replies
    1267 Views
    Last post by JayTee
  • I-Optron CEM 120 EC2
    by starman »
    5 Replies
    2090 Views
    Last post by starman
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum