iOptron mounts

Discuss iOptron mounts.
  • Topics
    Replies
    Views
    Last post
  • Ioptron CEM70 Extra counter weight with C-11
    by TheButcher »
    4 Replies
    114 Views
    Last post by TheButcher
  • iOptron CEM70 tripod?
    by TheButcher »
    15 Replies
    285 Views
    Last post by TheButcher
  • CEM25P meridian flip settings for AP.
    by asanmax »
    0 Replies
    184 Views
    Last post by asanmax
  • iOptron Snuggling--Not A Convenient Arrangement
    by JayTee »
    6 Replies
    370 Views
    Last post by Lady Fraktor
  • Favor To Ask Of An iOptron CEM60 Owner
    by jpelli »
    5 Replies
    213 Views
    Last post by jpelli
  • Can a Celestron CGE Heavy Duty Tripod Be Made To Adapt to an iOptron CEM60 Mount?
    by jpelli »
    2 Replies
    224 Views
    Last post by jpelli
  • ioptron smartstar 8500 dob telescope mounts backwards. cant align
    by realflow100 »
    41 Replies
    1462 Views
    Last post by realflow100
  • Counterweight to balance camera lens
    by realflow100 »
    8 Replies
    311 Views
    Last post by realflow100
  • Aligning a camera to a dovetail L bracket adapter accurately?
    by realflow100 »
    8 Replies
    306 Views
    Last post by realflow100
  • CEM 60 -- All The Pieces Parts Have Finally Arrived
    by JayTee »
    3 Replies
    273 Views
    Last post by Juno16
  • Fixing trailing/tracking problem? Please help! ioptron smartstar E8500R
    by realflow100 »
    31 Replies
    836 Views
    Last post by realflow100
  • CEM60-Issue w/Adding Custom Comets
    by XwarpfactorX »
    5 Replies
    381 Views
    Last post by 515bonner
  • play/slack in ioptron-E 8500 causing jittery tracking?
    by realflow100 »
    1 Replies
    324 Views
    Last post by realflow100
  • Connecting hardware thru CEM 60 USB ports
    by JeffBevan »
    2 Replies
    265 Views
    Last post by JeffBevan
  • CEM40
    by 515bonner »
    5 Replies
    906 Views
    Last post by 515bonner
  • CEM 60 Legs, Which One?
    by JayTee »
    5 Replies
    712 Views
    Last post by JayTee
  • CEM60 GPS Failure
    by Harmonious »
    5 Replies
    1255 Views
    Last post by Harmonious
  • Polare alignment of IEQ 30
    by dagadget »
    2 Replies
    466 Views
    Last post by dagadget
  • iOptron Az Mount Pro
    by smp »
    16 Replies
    2119 Views
    Last post by Myk Rian
  • Galvanic corrosion
    by XCalRocketMan »
    5 Replies
    570 Views
    Last post by OzEclipse
  • IOptron EQ30 Pro and GPS data delay
    by Chicca »
    5 Replies
    960 Views
    Last post by dagadget
  • CEM 60 Sync to Slew
    by JeffBevan »
    0 Replies
    477 Views
    Last post by JeffBevan
  • Mounts Are Like Telescopes
    by 515bonner »
    11 Replies
    956 Views
    Last post by yobbo89
  • CEM40 EC Review Part 3
    by STEVE333 »
    1 Replies
    844 Views
    Last post by STEVE333
  • CEM40 EC Review Part 1
    by STEVE333 »
    8 Replies
    4266 Views
    Last post by tom3.1416
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum