iOptron mounts

Discuss iOptron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • ioptron smartstar 8500 dob telescope mounts backwards. cant align
    by realflow100 »
    19 Replies
    152 Views
    Last post by realflow100
  • play/slack in ioptron-E 8500 causing jittery tracking?
    by realflow100 »
    1 Replies
    84 Views
    Last post by realflow100
  • Connecting hardware thru CEM 60 USB ports
    by JeffBevan »
    2 Replies
    85 Views
    Last post by JeffBevan
  • CEM60-Issue w/Adding Custom Comets
    by XwarpfactorX »
    3 Replies
    57 Views
    Last post by XwarpfactorX
  • CEM40
    by 515bonner »
    5 Replies
    554 Views
    Last post by 515bonner
  • CEM 60 Legs, Which One?
    by JayTee »
    5 Replies
    263 Views
    Last post by JayTee
  • CEM60 GPS Failure
    by Harmonious »
    5 Replies
    732 Views
    Last post by Harmonious
  • Polare alignment of IEQ 30
    by dagadget »
    2 Replies
    211 Views
    Last post by dagadget
  • iOptron Az Mount Pro
    by smp »
    16 Replies
    1558 Views
    Last post by Myk Rian
  • Galvanic corrosion
    by XCalRocketMan »
    5 Replies
    292 Views
    Last post by OzEclipse
  • IOptron EQ30 Pro and GPS data delay
    by Chicca »
    5 Replies
    660 Views
    Last post by dagadget
  • CEM 60 Sync to Slew
    by JeffBevan »
    0 Replies
    265 Views
    Last post by JeffBevan
  • Mounts Are Like Telescopes
    by 515bonner »
    11 Replies
    598 Views
    Last post by yobbo89
  • CEM40 EC Review Part 3
    by STEVE333 »
    1 Replies
    509 Views
    Last post by STEVE333
  • CEM40 EC Review Part 1
    by STEVE333 »
    8 Replies
    3258 Views
    Last post by tom3.1416
  • CEM60 Balancing
    by ic_1101 »
    2 Replies
    333 Views
    Last post by ic_1101
  • iOptron Duel "DV" Saddle
    by Don Quixote »
    3 Replies
    371 Views
    Last post by Don Quixote
  • CEM40 EC Review Part 2
    by STEVE333 »
    15 Replies
    2520 Views
    Last post by chartram
  • iOptron Mounts and iPolar
    by 515bonner »
    2 Replies
    379 Views
    Last post by STEVE333
  • cem40 mount performance
    by sarg314 »
    1 Replies
    388 Views
    Last post by STEVE333
  • CEM60 6-pole connector for focuser
    by KathyNS »
    2 Replies
    364 Views
    Last post by STEVE333
  • iOptron CEM40
    by Voyageur »
    4 Replies
    630 Views
    Last post by STEVE333
  • My New iOptron CEM40 EC
    by STEVE333 »
    4 Replies
    671 Views
    Last post by STEVE333
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum