Celestron mounts

Discuss Celestron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • Skipping Alignment?
    by 1cor29 »
    21 Replies
    7101 Views
    Last post by Graeme1858 Great Britain
  • WiFi capabilities of Meade LX85 ACF
    by boese1978@q.com United States of America »
    1 Replies
    142 Views
    Last post by Bigzmey United States of America
  • Celestron Heavy Duty Manual Alt Az with tripod
    by helicon United States of America »
    3 Replies
    445 Views
    Last post by helicon United States of America
  • New Accessory Tray
    by SparWeb Canada »
    2 Replies
    278 Views
    Last post by helicon United States of America
  • I potentially fixed my mount.
    by Jnicholes United States of America »
    16 Replies
    832 Views
    Last post by Graeme1858 Great Britain
  • I need creat a new Accessory Tray
    by Ward Brazil »
    9 Replies
    372 Views
    Last post by SparWeb Canada
  • Re-Greasing my CGX Worm Drives
    by Graeme1858 Great Britain »
    26 Replies
    1601 Views
    Last post by JayTee United States of America
  • Hand controller.
    by Tillibobs Great Britain »
    8 Replies
    438 Views
    Last post by Tillibobs Great Britain
  • Yet another mount issue.
    by Jnicholes United States of America »
    27 Replies
    2361 Views
    Last post by Jnicholes United States of America
  • Astromaster 114
    by Lord conDioin Canada »
    3 Replies
    791 Views
    Last post by JayTee United States of America
  • Tasco And Celestron -- Will It Work?
    by JayTee United States of America »
    2 Replies
    750 Views
    Last post by JayTee United States of America
  • Am I A Sucker?
    by JayTee United States of America »
    18 Replies
    2282 Views
    Last post by Ylem United States of America
  • SE6 Mount
    by Greenman Great Britain »
    2 Replies
    719 Views
    Last post by JayTee United States of America
  • Is PEC necessary with ASIAIR?
    by psy1280 »
    1 Replies
    876 Views
    Last post by Gordon United States of America
  • CGX RA spike/PHD2 Log viewer
    by KC_Astro_Mutt »
    4 Replies
    1335 Views
    Last post by AstroBee United States of America
  • AVX Lights up but doesn't boot or respond
    by StarLord101 »
    24 Replies
    8659 Views
    Last post by turboscrew
  • Does Avx mount beep normally on power on?
    by StarLord101 »
    4 Replies
    1176 Views
    Last post by goldstar
  • CGX-L keeps hitting switch limits!?
    by UlteriorModem »
    21 Replies
    3632 Views
    Last post by UlteriorModem
  • Celesron CGX / CGX-L Celestron or Synta?
    by UlteriorModem »
    1 Replies
    1063 Views
    Last post by JayTee United States of America
  • Another bizarre mount issue.
    by Jnicholes United States of America »
    4 Replies
    1518 Views
    Last post by AstroBee United States of America
  • Another SE mount question: set goto?
    by gregl »
    7 Replies
    6628 Views
    Last post by Lady Fraktor Slovakia
  • CGX mount in the cold
    by I Am Marsha »
    11 Replies
    8593 Views
    Last post by speedster
  • Mount issue
    by Jnicholes United States of America »
    23 Replies
    24657 Views
    Last post by Jnicholes United States of America
  • iOptron iPolar
    by 1cor29 »
    0 Replies
    2569 Views
    Last post by 1cor29
  • Advance VX Celestron Mounts
    by arizawilliams »
    8 Replies
    6921 Views
    Last post by arizawilliams
New Topic

Return to Board Index

Forum permissions


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum