Emergency maintenance will be performed on
theskysearchers.com server today between the hours of 9:00
PM and 4:00 AM EDT. This maintenance is necessary to install a
critical security patch. Downtime is expected to be less than
10 minutes.

(Posted On: Sep 15, 2021, 10:36 AM Eastern)

Celestron mounts

Discuss Celestron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • C5 controller?
    by Billd »
    1 Replies
    250 Views
    Last post by Lady Fraktor
  • AVX Lights up but doesn't boot or respond
    by StarLord101 »
    10 Replies
    856 Views
    Last post by Lady Fraktor
  • Celestron CGX-L RTC Battery
    by UlteriorModem »
    11 Replies
    3873 Views
    Last post by dagadget
  • Went out the other night,
    by Greenman »
    5 Replies
    1510 Views
    Last post by Greenman
  • Uth oh... Dec switch fail?
    by UlteriorModem »
    25 Replies
    5822 Views
    Last post by Richieb
  • Nexstar SE4
    by Astroglide65 »
    7 Replies
    1233 Views
    Last post by JayTee
  • WAAAAAT???
    by Astroglide65 »
    4 Replies
    1464 Views
    Last post by turboscrew
  • Mount Setup
    by Graeme1858 »
    15 Replies
    2116 Views
    Last post by turboscrew
  • Winter project 1 done hard standing & positioning
    by Greenman »
    6 Replies
    1038 Views
    Last post by Greenman
  • CGX Backlash and guiding problems
    by AstroBee »
    11 Replies
    3147 Views
    Last post by Graeme1858
  • CGX mount in the cold
    by I Am Marsha »
    10 Replies
    1531 Views
    Last post by Lady Fraktor
  • AVX and PHD2
    by Astroglide65 »
    7 Replies
    971 Views
    Last post by Astroglide65
  • AVX - Have you seen this motor behavior?? - Need Advice
    by jthommes »
    9 Replies
    1369 Views
    Last post by jthommes
  • dead short?
    by GH713 »
    5 Replies
    1594 Views
    Last post by JayTee
  • Lost in space?
    by Astroglide65 »
    5 Replies
    1732 Views
    Last post by Astroglide65
  • Celestron hand control: where to input lat. and long.?
    by gregl »
    8 Replies
    1907 Views
    Last post by Greenman
  • Another SE mount question: set goto?
    by gregl »
    5 Replies
    1598 Views
    Last post by Ylem
  • Calibrate Mount...
    by UlteriorModem »
    19 Replies
    4709 Views
    Last post by Astrovetteman
  • So Far So Good
    by Astrovetteman »
    3 Replies
    1253 Views
    Last post by Astrovetteman
  • Celestron CG-4 Vs. Orion Skyview Pro
    by Refractordude »
    2 Replies
    1719 Views
    Last post by Ylem
  • Anybody had pc troubles after connecting hc/mount?
    by StarLord101 »
    5 Replies
    1694 Views
    Last post by Greenman
  • Not the mount, but the tripod
    by FerrariMX5 »
    4 Replies
    1512 Views
    Last post by JayTee
  • Free fix for replacing AVX motor board with new ver
    by StarLord101 »
    14 Replies
    2755 Views
    Last post by StarLord101
  • Celestron EQ-130 MD RA/Dec
    by Timmmsa »
    8 Replies
    1844 Views
    Last post by janagn
  • 8SE alignment issue with skysense.
    by SPIE7 »
    1 Replies
    1025 Views
    Last post by Lady Fraktor
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum