Celestron mounts

Discuss Celestron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • AVX Lights up but doesn't boot or respond
    by StarLord101 »
    10 Replies
    278 Views
    Last post by Lady Fraktor
  • Celestron CGX-L RTC Battery
    by UlteriorModem »
    11 Replies
    3552 Views
    Last post by dagadget
  • Went out the other night,
    by Greenman »
    5 Replies
    1368 Views
    Last post by Greenman
  • Uth oh... Dec switch fail?
    by UlteriorModem »
    25 Replies
    5348 Views
    Last post by Richieb
  • Nexstar SE4
    by Astroglide65 »
    7 Replies
    986 Views
    Last post by JayTee
  • WAAAAAT???
    by Astroglide65 »
    4 Replies
    1331 Views
    Last post by turboscrew
  • Mount Setup
    by Graeme1858 »
    15 Replies
    1791 Views
    Last post by turboscrew
  • Winter project 1 done hard standing & positioning
    by Greenman »
    6 Replies
    881 Views
    Last post by Greenman
  • CGX Backlash and guiding problems
    by AstroBee »
    11 Replies
    2768 Views
    Last post by Graeme1858
  • CGX mount in the cold
    by I Am Marsha »
    10 Replies
    1330 Views
    Last post by Lady Fraktor
  • AVX and PHD2
    by Astroglide65 »
    7 Replies
    812 Views
    Last post by Astroglide65
  • AVX - Have you seen this motor behavior?? - Need Advice
    by jthommes »
    9 Replies
    1203 Views
    Last post by jthommes
  • dead short?
    by GH713 »
    5 Replies
    1425 Views
    Last post by JayTee
  • Lost in space?
    by Astroglide65 »
    5 Replies
    1551 Views
    Last post by Astroglide65
  • Celestron hand control: where to input lat. and long.?
    by gregl »
    8 Replies
    1682 Views
    Last post by Greenman
  • Another SE mount question: set goto?
    by gregl »
    5 Replies
    1389 Views
    Last post by Ylem
  • Calibrate Mount...
    by UlteriorModem »
    19 Replies
    4342 Views
    Last post by Astrovetteman
  • So Far So Good
    by Astrovetteman »
    3 Replies
    1108 Views
    Last post by Astrovetteman
  • Celestron CG-4 Vs. Orion Skyview Pro
    by Refractordude »
    2 Replies
    1586 Views
    Last post by Ylem
  • Anybody had pc troubles after connecting hc/mount?
    by StarLord101 »
    5 Replies
    1549 Views
    Last post by Greenman
  • Not the mount, but the tripod
    by FerrariMX5 »
    4 Replies
    1374 Views
    Last post by JayTee
  • Free fix for replacing AVX motor board with new ver
    by StarLord101 »
    14 Replies
    2431 Views
    Last post by StarLord101
  • Celestron EQ-130 MD RA/Dec
    by Timmmsa »
    8 Replies
    1678 Views
    Last post by janagn
  • 8SE alignment issue with skysense.
    by SPIE7 »
    1 Replies
    949 Views
    Last post by Lady Fraktor
  • Cargo Company Lost Advanced VX Tripod
    by okeania »
    12 Replies
    1928 Views
    Last post by okeania
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum