Celestron mounts

Discuss Celestron mounts.
New Topic
  • Topics
    Replies
    Views
    Last post
  • Went out the other night,
    by Greenman »
    5 Replies
    436 Views
    Last post by Greenman
  • Uth oh... Dec switch fail?
    by UlteriorModem »
    25 Replies
    4193 Views
    Last post by Richieb
  • Nexstar SE4
    by Astroglide65 »
    7 Replies
    474 Views
    Last post by JayTee
  • Celestron CGX-L RTC Battery
    by UlteriorModem »
    10 Replies
    2452 Views
    Last post by UlteriorModem
  • WAAAAAT???
    by Astroglide65 »
    4 Replies
    992 Views
    Last post by turboscrew
  • Mount Setup
    by Graeme1858 »
    15 Replies
    1172 Views
    Last post by turboscrew
  • Winter project 1 done hard standing & positioning
    by Greenman »
    6 Replies
    549 Views
    Last post by Greenman
  • CGX Backlash and guiding problems
    by AstroBee »
    11 Replies
    1937 Views
    Last post by Graeme1858
  • CGX mount in the cold
    by I Am Marsha »
    10 Replies
    951 Views
    Last post by Lady Fraktor
  • AVX and PHD2
    by Astroglide65 »
    7 Replies
    544 Views
    Last post by Astroglide65
  • AVX - Have you seen this motor behavior?? - Need Advice
    by jthommes »
    9 Replies
    832 Views
    Last post by jthommes
  • dead short?
    by GH713 »
    5 Replies
    1071 Views
    Last post by JayTee
  • Lost in space?
    by Astroglide65 »
    5 Replies
    1250 Views
    Last post by Astroglide65
  • Celestron hand control: where to input lat. and long.?
    by gregl »
    8 Replies
    1274 Views
    Last post by Greenman
  • Another SE mount question: set goto?
    by gregl »
    5 Replies
    1020 Views
    Last post by Ylem
  • Calibrate Mount...
    by UlteriorModem »
    19 Replies
    3542 Views
    Last post by Astrovetteman
  • So Far So Good
    by Astrovetteman »
    3 Replies
    839 Views
    Last post by Astrovetteman
  • Celestron CG-4 Vs. Orion Skyview Pro
    by Refractordude »
    2 Replies
    1220 Views
    Last post by Ylem
  • Anybody had pc troubles after connecting hc/mount?
    by StarLord101 »
    5 Replies
    1209 Views
    Last post by Greenman
  • Not the mount, but the tripod
    by FerrariMX5 »
    4 Replies
    1034 Views
    Last post by JayTee
  • Free fix for replacing AVX motor board with new ver
    by StarLord101 »
    14 Replies
    1707 Views
    Last post by StarLord101
  • Celestron EQ-130 MD RA/Dec
    by Timmmsa »
    8 Replies
    1307 Views
    Last post by janagn
  • 8SE alignment issue with skysense.
    by SPIE7 »
    1 Replies
    725 Views
    Last post by Lady Fraktor
  • Cargo Company Lost Advanced VX Tripod
    by okeania »
    12 Replies
    1557 Views
    Last post by okeania
  • Looking at AVX Mount for my 8SE
    by Ed217 »
    17 Replies
    3556 Views
    Last post by Kerry C.
New Topic

Return to Board Index

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum